Recent comments

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

I tried #4 and it cleared the "mismatched entity and/or field definitions error"

Thanks

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

An FYI, I applied MR8487 to 2 of my sites and the error is gone.

Thanks!

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

I tried #14 and that did not resolve my issue that only started when I installed 10.3.0-rc1.

I am getting this same error on every site I have upgraded.

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

I applied MR !41 and the error is gone.

Thanks!

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

Merge request !70 fixed my issue.

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

I tried MR !5005 and it did not work. I was able to use #21 successfully.

I am on 10.2.6 using php 8.2.18

Thanks

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

Hi Juergen, I just tried it out. Thanks! It works great!

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

Has there been any movement on this issue?

I tried to apply the patch but it fails to apply.

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

Merge request !86 did not work for me. I tried Merge request !70 and found that worked for me in conjunction with `patch at https://git.drupalcode.org/project/drupal/-/merge_requests/5684.patch` as suggested in step #18

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

I tried both patches MR!5919 & MR!5942 and they both worked fine.

For now I will keep MR!5942 applied.

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

@Wim Leers you asked for a couple of files from my other issue, so I'll copy them here. Hope this helps. I'll also include what my Style Plugin & Source Editing settings are showing on the old site (D10.1.5.) and the new site (D10.2.0).


Source Editing:

Original (D10.1.5)
    <cite> <span> <dl class> <dt class> <dd class> <iframe allow allowfullscreen src width height frameborder> <blockquote cite> <ul type> <ol type> <h2 id class> <h3 id class> <h4 id class> <h5 id class> <h6 id class> <a hreflang accesskey id rel target title class> <img data-entity-substitution class> <p class>
    
Current (D10.2.0)
    <cite> <span> <dl class> <dt class> <dd class> <iframe allow allowfullscreen src width height frameborder>
    
Style Plugins:

Original (D10.1.5)
    a.button|Button
    p.note|Note
    p.large|Larger text
    h1.node__title|Page title
    img.border|Add a border
    img.display-left|Float left
    img.display-right|Float right
    p.h2|H2
    p.h3|H3
    p.h4|H4

Current (D10.2.0)
    a.button|Button
    p.note|Note
    p.large|Larger text
    h1.node__title|Page title
    img.border|Add a border
    img.display-left|Float left
    img.display-right|Float right
    p.h2|H2
    p.h3|H3
    p.h4|H4

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

Here are the two files you requested.

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

joshuami ask me to share the example of the code in my edit source and style plugins on my ckeditor5 basic text filter:

Source Editing:

Original (D10.1.5)
    <cite> <span> <dl class> <dt class> <dd class> <iframe allow allowfullscreen src width height frameborder> <blockquote cite> <ul type> <ol type> <h2 id class> <h3 id class> <h4 id class> <h5 id class> <h6 id class> <a hreflang accesskey id rel target title class> <img data-entity-substitution class> <p class>
    
Current (D10.2.0)
    <cite> <span> <dl class> <dt class> <dd class> <iframe allow allowfullscreen src width height frameborder>
    
Style Plugins:

Original (D10.1.5)
    a.button|Button
    p.note|Note
    p.large|Larger text
    h1.node__title|Page title
    img.border|Add a border
    img.display-left|Float left
    img.display-right|Float right
    p.h2|H2
    p.h3|H3
    p.h4|H4

Current (D10.2.0)
    a.button|Button
    p.note|Note
    p.large|Larger text
    h1.node__title|Page title
    img.border|Add a border
    img.display-left|Float left
    img.display-right|Float right
    p.h2|H2
    p.h3|H3
    p.h4|H4

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

I tried patch #3 and I still get errors.

Drupal\Core\Entity\Query\QueryException: Entity queries must explicitly set whether the query should be access checked or not. See Drupal\Core\Entity\Query\QueryInterface::accessCheck().

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

Is there a scheduled date for the D10 release yet?

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

drupal/hook_event_dispatcher:^4.0@RC is available and supports D10 but layout_builder_kit doesn't support this version.

This is what I get:

composer require 'drupal/hook_event_dispatcher:^4.0@RC'

Problem 1
- Root composer.json requires drupal/hook_event_dispatcher ^4.0@RC, found drupal/hook_event_dispatcher[4.0.0-rc1] but these were not loaded, likely because it conflicts with another require.
Problem 2
- drupal/core_event_dispatcher is locked to version 3.3.4 and an update of this package was not requested.
- drupal/core_event_dispatcher 3.3.4 requires drupal/hook_event_dispatcher * -> found drupal/hook_event_dispatcher[1.0.0, ..., 1.29.0, 2.0.0, ..., 2.5.0, 3.0.0-rc1, ..., 3.3.4, 4.0.0-rc1] but these were not loaded, likely because it conflicts with another require.
Problem 3
- drupal/layout_builder_kit is locked to version 2.0.0-alpha2 and an update of this package was not requested.
- drupal/layout_builder_kit 2.0.0-alpha2 requires drupal/hook_event_dispatcher ^3 -> found drupal/hook_event_dispatcher[3.0.0-rc1, ..., 3.3.4] but it conflicts with your root composer.json require (^4.0@RC).

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

Has there been any movement on this issue?

I get the same composer errors.

Your requirements could not be resolved to an installable set of packages.

Problem 1
- Root composer.json requires drupal/taxonomy_image ^1.0@alpha -> satisfiable by drupal/taxonomy_image[1.0.0-alpha1, 1.0.0-alpha2].
- drupal/taxonomy_image[1.0.0-alpha1, ..., 1.0.0-alpha2] require drupal/core ^8 -> found drupal/core[8.0.0-beta6, ..., 8.9.x-dev] but the package is fixed to 9.5.10 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

I'm currently at php 8.1, Core 9.5.10

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

I applied patch #15 and it has cleared up all the RouteNotFoundExceptions I was getting.

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

In the future it would be helpful for others to mention in the requirements that it doesn't work with ckeditor 5.

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

I'm using ckeditor 5. Thanks for the heads up.

πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

I ran into the same issue. This is not a multidev.

I am using Core 10.0.8
automatic_updates 8.x-2.7

I installed automatic_updates using ddev composer require drupal/automatic_updates

Next I run ddev drush pm:install automatic_updates and I get the following error:

In CheckExceptionOnInvalidReferenceBehaviorPass.php line 83:
                                                                                                                                                                                    
  The service "project_browser.composer_validator.core_not_updated" has a dependency on a non-existent service "Drupal\package_manager\PathLocator". Did you mean this: "package_manager.path_locator"?                                                                                                                                                            
                                                                                                                                                                                    
Failed to run drush pm:install automatic_updates: exit status 1

I uninstalled auromatic_updates using ddev drush pm:uninstall automatic_updates and I get this message:

In PmCommands.php line 177:
                                                                                          
  The following module(s) are not installed: automatic_updates. No modules to uninstall.  
                                                                                         
Failed to run drush pm:uninstall automatic_updates: exit status 1

I remove the module using ddev composer remove drupal/automatic_updates

After uninstalling automatic_updates when I run database update ddev drush updb I get this error:

 [error]   (Currently using Missing or invalid modules The following modules are marked as installed in the core.extension configuration, but they are missing:
 * automatic_updates
 * package_manager

Review the  suggestions for resolving this incompatibility [1] to repair your installation, and then re-run update.php.

[1] https://www.drupal.org/docs/updating-drupal/troubleshooting-database-updates) 

 // Requirements check reports errors. Do you wish to continue?: yes.
πŸ‡ΊπŸ‡ΈUnited States Adrianm6254

I tried tested the PR and everything worked great.

In the text file I have the commands I ran as well as the output. BTW, it did fail when I started with a cache-clear after installing the updated module.

Production build 0.69.0 2024