Rename and prefix actions with module name

Created on 23 January 2025, 2 months ago

Problem/Motivation

It is a best practice to prefix the ID of actions (any plugin) with the name of the provider/module.

After upgrading to file_delete v3 the system.action.immediate_delete and system.action.mark_file_for_deletion are created; While not a big problem, I think these names are not very clear. Something like system.action.file_delete_immediately would have been better.

Steps to reproduce

Proposed resolution

Rename actions:

  • mark_file_for_deletion to file_delete_mark_temporary (or file_delete_scheduled?)
  • immediate_delete to file_delete_immediately

Add an update hook to update existing action config files.

Remaining tasks

User interface changes

API changes

Data model changes

Feature request
Status

Active

Version

3.0

Component

Code

Created by

🇳🇱Netherlands casey

Live updates comments and jobs are added and updated live.
Sign in to follow issues

Merge Requests

Comments & Activities

Production build 0.71.5 2024