- Issue created by @just_like_good_vibes
- Merge request !346Resolve #3511112 "2.0.1 make componenent" → (Merged) created by just_like_good_vibes
- 🇫🇷France just_like_good_vibes PARIS
Pierre, please check the hook name "component_built", we need a better name
- 🇫🇷France pdureau Paris
Naming is hard :)
We are allowing the alteration of a slot source value:
protected function buildSlot(array $build, string $slot_id, array $definition, array $configuration, array $contexts): array { ... foreach ($configuration["sources"] as $source_configuration) { ... $source_value = $source->getValue($slot_prop_type) ?? []; $this->moduleHandler->alter('component_built', $source_value, $source_configuration); }
So, instead of
hook_component_built_alter
(component_built
), we can proposehook_component_slot_source_alter
(component_slot_source
)? Is it too long? - 🇫🇷France pdureau Paris
Discussed with Mikael. We are not altering the source but the source value:
hook_component_slot_value_alter
(component_slot_value
)hook_sdc_slot_value_alter
(sdc_slot_value
)hook_ui_patterns_slot_value_alter
(ui_patterns_slot_value
)hook_slot_value_alter
(slot_value
) if the previous ones are too long
But I still prefer the "slot_source" one ;)
- 🇫🇷France pdureau Paris
Thinking aloud: Is it limited to slot sources ? Why not opening this alter to prop sources?
- 🇫🇷France just_like_good_vibes PARIS
we voted for ui_patterns_source_value, let the magic happens now
-
just_like_good_vibes →
committed 6ee5db3b on 2.0.x
Issue #3511112 by just_like_good_vibes, pdureau, mogtofu33, christian....
-
just_like_good_vibes →
committed 6ee5db3b on 2.0.x
- 🇩🇪Germany Christian.wiedemann
just_like_good_vibes → credited christian.wiedemann → .
Automatically closed - issue fixed for 2 weeks with no activity.