8.x-4.x branch in Git
Drupal 8 is now in its second beta. API changes are still happening, but it should be fine to start converting modules now.
First, I have to clean up Drupal 7 to get it into a state ready for porting. If I postpone this cleanup to Drupal 8, it will probably be much harder.
There are many features I wanted to get into Drupal 7 but did not have time to do, and I didn't receive any patches that added these. Hopefully, these will be easier in Drupal 8 or will at least follow more standardized patterns (making FillPDF templates into entities, filling with data from any entity and not just nodes/webforms, etc.).
(edit: Yep! I've done both of those so far! Wasn't able to dump the query string from the URL format, though.)
Launch a full Drupal 8 version. (pretty much achieved; touch-ups remain)
Launch a Drupal 8 version that has approximate feature parity with Drupal 7; no new features, no new Drupal APIs (conceptually, since obviously the APIs have changed) used. This will be 8.x-3.x.
- Check code with Coder Review
#2624090: Fix Coder violations for Drupal ruleset. →
- TESTS TESTS TESTS. For access checking, PDF generation, the various FillPdfForm/FillPdfFormField settings, etc.
#1393056: [Meta] Write tests →
- Figure out how to show actual file locations for private, uploaded PDFs shown using the file field in the fillpdf_forms view.
#2624120: Show actual file locations in FillPDF Forms view →
- Create a class to hold FillPdfLinkContext
information. This will replace the job of the $context
array because I can make an interface and document it, then point people there instead of telling them to look at FillPdfManipulator::parseLink()
.
#2624122: Create ValueObject-pattern class to replace $context array →
- Add check for xmlrpc module (moved to contrib in D8) to FillPdfSettingsForm — the overview page already has one
#2624138: Add ModuleHandler::moduleExists() check for xmlrpc to FillPdfSettingsForm →
- Rename classes to be less redundant, e.g. DownloadAction vs. FillPdfDownloadAction, etc. They're already namespaced. Ref:
https://www.drupal.org/node/608152#naming →
#2624144: Revisit naming convention for classes →
- Refactor \Drupal\fillpdf\Controller\HandlePdfController
to contain less original logic. It should almost exclusively use services. Note: This is related to having a canonical FillPdfForm
route.
#2624156: Move all original logic in HandlePdfController into services →
- Integrate with D8 Rules
#2624162: Rules integration (D8) →
- FillPdfForm field type (@FieldType
) for entities, maybe themeable as a button or link
#2343507: FillPDF field →
Actually, I pretty much had to do this, so I'm just going to use this section for roadmap stuff that I don't wind up getting done.
Leave a comment here :)
Fixed
4.0
Code
Issue summaries save everyone time if they are kept up-to-date. See Update issue summary task instructions.
Not all content is available!
It's likely this issue predates Contrib.social: some issue and comment data are missing.