Problem/Motivation
There is a hook called hook_ranking(), which is invoked in \Drupal\node\Plugin\Search\NodeSearch::getRankings().
This is not a great name for a hook. It should be called hook_node_search_ranking() instead.
Proposed resolution
We cannot really delete a hook at this point in the 8.x cycle. So, we'll add the new hook and deprecate the old hook. In 9.x we will remove the old hook. (See
#2690437: Remove the deprecated hook_ranking() and the code invoking it β
for that.)
Remaining tasks
a) In the core/modules/node/node.api.php file, copy the existing documentation block and function/body for hook_ranking(), and in the copy, change the name to hook_node_search_ranking().
b) In the same node.api.php file, replace everything except the first line of the documentation for the hook_ranking() function with an @deprecated message. See
https://www.drupal.org/node/1354#deprecated β
The message should say something like:
in Drupal 8.2.0, will be removed before Drupal 9.0.0. Use hook_node_search_ranking() instead.
c) In \Drupal\node\Plugin\Search\NodeSearch::getRankings(), invoke both the old hook and the new hook and add the results together using array addition.
d) Change the function names for the core implementations of this hook, and their first-line documentation, to be for the new hook. You can find these listed on
https://api.drupal.org/api/drupal/core!modules!node!node.api.php/functio...
e) Write a change record about the deprecated hook.
User interface changes
None.
API changes
hook_ranking() is deprecated in favor of hook_node_search_ranking(), but both are supported until 9.0.
Data model changes
None.
Original issue report (for readability of first few comments)
node and comment module's implement a 'hook_ranking' that is invoked by node modules' node_search_admin.
Related to
#237748: Decouple core search module implementations from node and user module (and turn search/node and search/user to views). β
, I don't think this node_search_admin belongs in node module at all (belongs in search module). Regardless, hook_ranking just doesn't seem important enough to get away with violating namespace rules. It should be something like hook_node_search_ranking, and then if can get the search-related code out of node module, it can change to hook_search_ranking.