[1.0.0-beta1] Rename *BaseInterface

Created on 15 September 2024, 7 months ago
Updated 16 September 2024, 7 months ago

Problem/Motivation

"PluginBase" or "Base" in IconExtractorPluginBaseInterface is mlisleading. This interface is not onmy for the abstract base class, but for all extractors.

Same with IconExtractorPluginFinderBaseInterface

Proposed resolution

Rename IconExtractorPluginBaseInterface: IconExtractorInterface (my preference) or IconExtractorPluginInterface

Rename IconExtractorPluginFinderBaseInterface: IconExtractorWithFinderInterfaceor something like that...

📌 Task
Status

Fixed

Version

1.0

Component

Code

Created by

🇫🇷France pdureau Paris

Live updates comments and jobs are added and updated live.
Sign in to follow issues

Merge Requests

Comments & Activities

Production build 0.71.5 2024