Rename UserNavigationBlock to NavigationUserBlock for class name consistency

Created on 8 May 2024, 2 months ago
Updated 4 June 2024, about 1 month ago

Problem/Motivation

There are 3 NavigationBlock plugin provided by Navigation module: NavigationMenuBlock, NavigationShortcutsBlock & UserNavigationBlock.

The later follow a different name pattern, nd would be great to have a single naming convention for these blocks.

Proposed resolution

  • Rename class UserNavigationBlock to NavigationUserBlock
  • Rename class UserNavigationBlockTest to NavigationUserBlockTest
  • Remove unused class property moduleHandler which is not being used while we are here

Remaining tasks

User interface changes

API changes

Data model changes

Release notes snippet

πŸ“Œ Task
Status

Fixed

Version

10.3 ✨

Component
NavigationΒ  β†’

Last updated about 9 hours ago

No maintainer
Created by

πŸ‡ͺπŸ‡ΈSpain plopesc Valladolid

Live updates comments and jobs are added and updated live.
  • Novice

    It would make a good project for someone who is new to the Drupal contribution process. It's preferred over Newbie.

Sign in to follow issues

Merge Requests

Comments & Activities

Production build 0.69.0 2024