Rename function bindClosureToClassMethod() to setMockedClassMethod() to be more clear

Created on 26 January 2023, almost 2 years ago
Updated 27 January 2023, almost 2 years ago

Problem/Motivation

Function bindClosureToClassMethod() has not so clear self-description, so it's beter to rename it to setMockedClassMethod(), and also change arguments order to more common:

-  public static function bindClosureToClassMethod(\Closure $closure, MockObject $class, string $method): void {
+  public static function setMockedClassMethod(MockObject $class, string $method, \Closure $closure): void {

Steps to reproduce

Proposed resolution

Remaining tasks

User interface changes

API changes

Data model changes

📌 Task
Status

Fixed

Version

1.0

Component

Code

Created by

🇦🇲Armenia murz Yerevan, Armenia

Live updates comments and jobs are added and updated live.
Sign in to follow issues

Comments & Activities

Production build 0.71.5 2024