- Issue created by @dakwamine
In the code, we have "render" as a key to identify that the value represents a rendered value.
But this is confusing because we designed a multiple phase rendering.
It starts with a pre-render, during which FieldValueAndOptions are collected.
Then a clean-up phase, which sorts the fields and removes unnecessary metadata.
Finally an alteration phase (a post-render), during the event EVENT__RENDERER__OUTPUT__RENDERED__PREFIX, which moves data according to "field location" config and perform additional things.
Having the data called "render" is confusing because it makes difficult for the programmer to know what it is working on, at which stage of the rendering process.
Better naming, such as "pre_render", "cleaned_render", "cacheable_render", "post_render", etc.
All!
To determine.
None.
Active
1.5
Code