- Issue created by @sidgrafix
I'm not entirely sure why a contributed module was aloud to or has it's name be that of a core drupal module (I understand newer versions of drupal having core module names that were previously contrib modules in previous versions of drupal - but that's not this), and this has caused me some headaches this past week.
Long story short I was cleaning up a drupal 7 site this past week that has been setup with composer. All modules initially installed with composer require (using the drupal composer project for drupal 7) .
One of the modules I use has a core contact module requirement (and the core contact module has always been installed) however you don't use composer to update or require drupal core modules (they are updated anytime core is) and for whatever reason this module also named "contact" gets installed by composer along with the module that requires core/contact module making this module the dependency instead of core/contact and changes the name of this modules install folder (in sites/all/modules) to contact-contact (which is weird in it self but beside the point).
Here is what is returned by composer when requiring contact_forms:
..$> composer require 'drupal/contact_forms:^1.9'
./composer.json has been updated
Running composer update drupal/contact_forms
Gathering patches from patch file.
Removing package cweagans/composer-patches so that it can be re-installed and re-patched.
- Removing cweagans/composer-patches (1.7.3)
> DrupalProject\composer\ScriptHandler::checkComposerVersion
Loading composer repositories with package information
Info from https://repo.packagist.org: #StandWithUkraine
Updating dependencies
Lock file operations: 2 installs, 0 updates, 0 removals
- Locking drupal/contact-contact (dev-2.x 8b2141c)
- Locking drupal/contact_forms (1.9.0)
Writing lock file
Installing dependencies from lock file (including require-dev)
Package operations: 3 installs, 0 updates, 0 removals
- Syncing drupal/contact-contact (dev-2.x 8b2141c) into cache
- Installing cweagans/composer-patches (1.7.3): Extracting archive
Gathering patches from patch file.
Gathering patches for dependencies. This might take a minute.
- Installing drupal/contact-contact (dev-2.x 8b2141c): Cloning 8b2141c054 from cache
- Installing drupal/contact_forms (1.9.0): Extracting archive
Package php-http/message-factory is abandoned, you should avoid using it. Use psr/http-factory instead.
Package webmozart/path-util is abandoned, you should avoid using it. Use symfony/filesystem instead.
Generating autoload files
25 packages you are using are looking for funding.
Use the `composer fund` command to find out more!
> DrupalProject\composer\ScriptHandler::createRequiredFiles
I can confirm this is the module composer is installing because the contact.info file is version 2.x-dev and I did a complete comparison from a downloaded zip of your package and the installed package at /contact-contact
In the composer.lock file where contact-contact is designated a drupal/module and then also listed under dependecies for the contact_foms has the source listed back to https://git.drupalcode.org/project/contact (which is this module)
The problem causes this module "same name as core module" (contact) to override the core module, it also cannot be removed with composer without removing contact_forms first.
I'm honestly not sure how long this has been happening but it is extremely frustrating. I had to remove contact_forms from composer to remove this module, then clear drupal cache so core contact would take back over and then manually install contact_forms from zip outside of composer making everything work as expected and using core contact module as it's dependency.
- Which isn't what I'd call ideal and defeats the purpose of managing drupal 7 with composer (should something happen and the site need to be moved or redeployed and I wasn't available to do it the contact_forms module may be overlooked which could lead to other problems...)
If it's possible could you change the name of this module? Which may mean recreating in another name and then having this project removed so as to avoid conflicts with composer and the core contact module in the future. Probably not but thought figure it wouldn't hurt to ask. And I do get this is supposed to be a drop-in replacement for contact to back-port features - I just don't think this is the right way to have done it.
Active
2.0
Code